GREETBoard – Stepper L6208 – Version 1.0

Das GREETBoard – Stepper L6208 ist ein Schrittmotor-Treiber, dessen Kernstück – wen wundert es – ein L6208 von STMicroelectronics ist. Der kleine Baustein hält eine Menge aus. So schafft er eine Motorspannung von bis zu 52V bei einem Dauerstrom von 2,8A. Dafür muss er natürlich gut gekühlt werden, sodass ich ihm einen hübschen Kühlkörper verpasst habe. Idealerweise passt dieser auch genau (haarscharf wäre hier auch noch angebracht) zwischen die Bohrlöcher der Abstandshalter. Dadurch können mehrere Module übereinander gestapelt werden. Was mir ganz besonders gut gefällt, ist dass die Schaltung ohne SMD-Bauteile auskommt und somit auch von Lötanfängern zu bewältigen ist.

Was mich bei den Testversionen gestört hat, war die Verwendung eines ganzen Ports für nur vier Signale. Der L6208 benötigt eigentlich mehr als diese vier Signale, aber zwei (Halb-Vollschritt und Fast/Slow-Decay) habe ich bereits seit den ersten Versuchen per Jumper gesetzt. Daher ist das GREETBoard – Stepper L6208 mit der Möglichkeit ausgerüstet, in den „Slave“-Modus geschaltet zu werden. Der „Master“ erhält seine Signale wie gehabt vom GREETBoard – ATMega128 über den 10-pol. Pfostenstecker. Damit sind dann vier Signalleitungen, VCC und GND belegt. Es bleiben also weitere vier Signalleitungen übrig, die der Master an den Slave durchschleift. Über ein Port können somit zwei Motoren angesteuert werden. Dafür müssen lediglich vier Jumper umgesteckt werden.

Auf dem folgenden Bild ist der 10-polige Pfostenstecker für die Verbindung zum Mikrocontroller zu erkennen. Direkt darunter sitzt der 6-polige Pfostenstecker für die Verbindung mit einem zweiten GREETBoard – Stepper L6208.

GREETBoard-Stepper L6208 - mit demontiertem Kühlkörper

GREETBoard-Stepper L6208 – mit demontiertem Kühlkörper

„Bitte anschnallen, Tische hochklappe, die Motoren starten in Kürze!“

So in etwa habe ich mich gefühlt, als die fertige Version 1.0 des GREETBoard – Stepper L6208 auf meinem Basteltisch stand und darauf wartete eingeschaltet zu werden. Nur noch eben das aktuellste Programm aufspielen, Motorspannung hochfahren, GREETBoard – ATMega128 einschalten und LOS!

Das war in etwa der dritte Versuch, aber der klappte dann auch ganz hervorragend. Leider habe ich bei der Erstellung der Platine VCC und GND miteinander vertauscht. Daher habe ich die Drähte des Flachbandkabels einzeln in die Anschlüsse der Pfostensteckers gelötet. Normalerweise hätte ich einfach nur die beiden Drähte für VCC und GND miteinander vertauschen und diese wieder in einen Pfostenbuchse klemmen müssen. Das ist mir leider zu spät eingefallen, ich Depp! Es funktioniert, sieht aber nicht so schön aus.

Zwei Motoren gleichzeitig laufen lassen

Vorweg möchte ich sagen, dass ich die Programme für den Einzel- und Doppelbetrieb in Kürze in einem separaten Artikel beschreiben werde. Hier und jetzt möchte ich das Video präsentieren, das ganz wunderbar den Doppelbetrieb zeigt.

Wie weiter

Natürlich wird es sehr bald eine Version 1.1 geben. Dort werde ich das Vertauschen von VCC und GND wieder korrigieren. Außerdem habe ich ein paar kleinere Änderungen an den Leiterbahnen vor, sodass die zusammenhängende GND-Fläche größer wird. Das sollte die Kühlleistung ein wenig verbessern (na ja, bislang bin ich nicht an die thermische Grenze gekommen. Aber wenn ich das Layout eh ändern muss, mache ich das gleich mit). Die Änderungen haben keinen Einfluss auf die Programmierung, daher kann ich die in der Zwischenzeit erklären. Aber dass mache ich später.

Ich freue mich sehr über euer Feedback. Per Kommentar und auch per Email.

Alles Gute, Euer Timo

2 Gedanken zu „GREETBoard – Stepper L6208 – Version 1.0

  1. Hallo Timo
    habe beim L6208 noch was gefunden.
    In deiner Stückliste gibst du für das Poti R10 2,5k an. In der Schaltung steht 5k, für R9 gibst du 22,1k an, in deiner Schaltung steht 30,9k. Die Diode D2 ist in der Schaltung aber nicht in der Stückliste, beim Elko C9 hast du 100uF angegeben, aber keine Spannung (63V ?).
    achim

  2. Hallo Achim,
    da sind tatsächlich ein paar Sachen durcheinander gekommen. R10 ist 2,5k Ohm und R9 22,1k Ohm. Da ist der Schaltplan leider nicht aktuell. Beim C9 (in der Stückliste) handelt es sich um einen 100µF/63V Kondensator. Im Schaltplan ist er jedoch mit C1 bezeichnet. Auch der C10 ist im Schaltplan fälschlicherweise mit C2 angegeben. Da habe ich wohl mal die Annotation geändert und vergessen den Plan zu aktualisieren. Danke für den Hinweis.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.